Skip to main content

Site Navigation

Your Account

Choose Language

Introduction

EDIT 7/25/17: Sadly, Sketchup has changed the map service they use to grab location data, so the aerial satellite imagery and 3D topography are no longer available, even in previous versions of Sketchup before 2017. As such, this guide no longer works.

This guide outlines the process for creating a 3D topographic model using free software.

You will also need the SketchUp STL extension, available for free through the Sketchup Extension Warehouse: https://extensions.sketchup.com/en/conte...

Tools

Parts

No parts specified.

  1. Open Sketchup.
    • Open Sketchup.

    • Navigate to the File menu > Geo-location > Add Location...

  2. Navigate to the area you want to make a model of.
    • Navigate to the area you want to make a model of.

    • In this case, I've chosen the highest point in the contiguous United States, Mt. Whitney (which I climbed in 2012).

  3. Once you get the borders exactly where you want them, click Select Region at the top right
    • Once you get the borders exactly where you want them, click Select Region at the top right

    • Take a screenshot of the resulting screen. We will reference the satellite imagery in a future step to flatten out certain parts (i.e. the lakes).

    • If you need a good (free) screenshot utility for Windows, try Greenshot.

    • Once you have the screenshot, click Grab to import the Google Earth mesh data into Sketchup.

  4. After a few seconds, a flat image of the area you just grabbed will show in the main Sketchup screen. Navigate to the File menu > Geo-location > Show Terrain. Navigate to the File menu > Geo-location > Show Terrain.
    • After a few seconds, a flat image of the area you just grabbed will show in the main Sketchup screen.

    • Navigate to the File menu > Geo-location > Show Terrain.

  5. With the Sketchup STL extension installed, you can navigate to the File menu > Export to STL and save the file. In case you need the extension, you can find it here: Sketchup STL Extension
    • With the Sketchup STL extension installed, you can navigate to the File menu > Export to STL and save the file.

    • In case you need the extension, you can find it here: Sketchup STL Extension

    • For Export unit choose Feet. You can realistically choose any unit you want, but choosing Feet will make the model more manageable in Blender, and you can always scale it again later.

  6. Open Blender and delete the cube from the startup scene. Blender has a feature called 'Clipping' that only shows the model at a certain distance, so in case your model is too big to show all of it, increase Clip in the properties area of 3D View to some large number (I use a series of six nines).
    • Open Blender and delete the cube from the startup scene.

    • Blender has a feature called 'Clipping' that only shows the model at a certain distance, so in case your model is too big to show all of it, increase Clip in the properties area of 3D View to some large number (I use a series of six nines).

  7. Navigate to the File menu > Import > Stl (.stl) and choose the file you exported from Sketchup. Once the model loads, press the S key (hotkey for scale) then enter .01 to scale it to 1/100th of its size. Hit Enter to save the scale. Your mouse cursor must be in the 3D View pane to use any hotkeys associated with the model, so if you don't see a change after pressing the key, check where your mouse is.
    • Navigate to the File menu > Import > Stl (.stl) and choose the file you exported from Sketchup.

    • Once the model loads, press the S key (hotkey for scale) then enter .01 to scale it to 1/100th of its size. Hit Enter to save the scale.

    • Your mouse cursor must be in the 3D View pane to use any hotkeys associated with the model, so if you don't see a change after pressing the key, check where your mouse is.

    • You might need to zoom out (mouse wheel) to see the whole model.

    • To remove the grid, navigate to the Properties section of 3D View, expand the Display section, and uncheck Grid Floor.

  8. We're going to edit the mesh manually, so we need to make the geometry easier to work with. With the mesh selected (it will have an orange border around it), press the Tab key to enter Edit mode.
    • We're going to edit the mesh manually, so we need to make the geometry easier to work with.

    • With the mesh selected (it will have an orange border around it), press the Tab key to enter Edit mode.

    • The mesh will highlight every edge and vertex in orange, indicating that they are all selected.

    • With everything still selected, press Alt+J to turn the mesh into quads instead of triangles.

    • Some of the squares along the sides might not change; that's okay. Areas that you need to edit will typically be turned into quads.

  9. Deselect everything by pressing the A key. In Properties, scroll down to the Background Images section, check the box, and click Add Image. Scroll down further to view the recently-shown options for Background Image and click Open.
    • Deselect everything by pressing the A key.

    • In Properties, scroll down to the Background Images section, check the box, and click Add Image.

    • Scroll down further to view the recently-shown options for Background Image and click Open.

    • Choose the screenshot you took in step 3.

  10. Navigate to the View menu at the bottom left of 3D View and switch to Orthographic view by clicking the View Persp/Ortho menu item (or simply press the Numpad 5 hotkey for this function). From the View menu, choose Top (or press the Numpad 7 hotkey). You will now see the model from above, looking down.
    • Navigate to the View menu at the bottom left of 3D View and switch to Orthographic view by clicking the View Persp/Ortho menu item (or simply press the Numpad 5 hotkey for this function).

    • From the View menu, choose Top (or press the Numpad 7 hotkey).

    • You will now see the model from above, looking down.

  11. Sometimes the exported model isn't perfectly aligned. If your model comes out rotated a little, you will need to correct this. Press the Tab key to exit Edit mode.
    • Sometimes the exported model isn't perfectly aligned. If your model comes out rotated a little, you will need to correct this.

    • Press the Tab key to exit Edit mode.

    • Press the R key and use your mouse to rotate the model so it is straight.

    • You can fine tune the rotation angle using the modifier field on the left.

  12. Scroll down Properties to reveal the Background Images options, if necessary. Click Front to bring the background image in front of the model.
    • Scroll down Properties to reveal the Background Images options, if necessary.

    • Click Front to bring the background image in front of the model.

    • Use the X and Y fields to position the model, and Rotation and Size to match the border to its edges. You might need to adjust the Opacity to get a good view.

  13. Some of the lakes in the model didn't quite come out flat, so we're going to manually flatten them. Zoom in to the area you want to flatten. Press Tab to enter Edit mode again.
    • Some of the lakes in the model didn't quite come out flat, so we're going to manually flatten them.

    • Zoom in to the area you want to flatten.

    • Press Tab to enter Edit mode again.

    • If the grid around the area you want to flatten isn't very high definition, you can subdivide the grid into smaller squares.

    • Change to Face select mode by clicking the icon at the bottom of the screen of the cube with one side highlighted.

    • Press the C key to use the Circle select tool, and use your mouse cursor to make the selection area bigger or smaller.

    • Select all the faces over the area you want to have more definition, then press Escape to exit Circle select mode.

    • Press the W key and choose Subdivide. You can do this more than once to get more definition, but be careful as too much detail can add unnecessary complexity to the model.

  14. Press A to deselect everything, then
    • Press A to deselect everything, then

    • Switch to Vertex select by clicking the icon of a cube with a dot at the top left near the bottom of the screen.

  15. Use Circle select again (hotkey: C), this time to select all the vertices inside the boundaries of the lake.
    • Use Circle select again (hotkey: C), this time to select all the vertices inside the boundaries of the lake.

    • Remember that you can always make the mesh more detailed by subdividing the geometry.

  16. Press Escape to exit Circle select.
    • Press Escape to exit Circle select.

    • Change Pivot center for rotation/scaling to Active Element.

    • This will help us in the next step by using the location of a selected vertex as the height to which the rest of the selected points will be adjusted.

  17. Use your middle mouse button to rotate the view so that you can see the height of the selected mesh. Choose a vertex is at the height you want the mesh to be flattened to, then, holding the Shift button on the keyboard, use your right mouse button to de-select then re-select it. This will change the Active Element to the vertex, which is now highlighted in white with the Axes centered on it.
    • Use your middle mouse button to rotate the view so that you can see the height of the selected mesh.

    • Choose a vertex is at the height you want the mesh to be flattened to, then, holding the Shift button on the keyboard, use your right mouse button to de-select then re-select it.

    • This will change the Active Element to the vertex, which is now highlighted in white with the Axes centered on it.

    • Press S (for scale), then Z (to constrain the movement to the Z axis), then 0 (for the height relative to the Active Element), then Enter (to finish the scale).

    • This will scale the height of all selected vertices to that of the one which was selected.

  18. From here, use the Smooth tool in Sculpt mode to smooth out any inconsistencies between the flat area and the rest of the model. From here, use the Smooth tool in Sculpt mode to smooth out any inconsistencies between the flat area and the rest of the model. From here, use the Smooth tool in Sculpt mode to smooth out any inconsistencies between the flat area and the rest of the model.
    • From here, use the Smooth tool in Sculpt mode to smooth out any inconsistencies between the flat area and the rest of the model.

  19. Repeat steps 13-18 for any other flat areas. Repeat steps 13-18 for any other flat areas. Repeat steps 13-18 for any other flat areas.
    • Repeat steps 13-18 for any other flat areas.

  20. Next, we'll make the model into a watertight object so we can export it for 3D printing.
    • Next, we'll make the model into a watertight object so we can export it for 3D printing.

    • Zoom out (mouse wheel) and deselect everything (hotkey: A).

  21. Switch to Edge select mode by clicking the icon of a cube with a line next to it near the bottom of the screen. Holding the Shift and Alt keys, right-click near each of the four sides of the square to select them. Holding the Shift and Alt keys, right-click near each of the four sides of the square to select them.
    • Switch to Edge select mode by clicking the icon of a cube with a line next to it near the bottom of the screen.

    • Holding the Shift and Alt keys, right-click near each of the four sides of the square to select them.

  22. Rotate the model (click and drag middle mouse button) so you can see under the model, roughly where you'll want the base to go. Press Shift+D (to duplicate the selection), then Z (to constrain movement to the Z axis), then move the selection roughly to the height you'll want the base to be at. Press Enter or left mouse click when you're satisfied.
    • Rotate the model (click and drag middle mouse button) so you can see under the model, roughly where you'll want the base to go.

    • Press Shift+D (to duplicate the selection), then Z (to constrain movement to the Z axis), then move the selection roughly to the height you'll want the base to be at.

    • Press Enter or left mouse click when you're satisfied.

  23. Switch back to Vertex select (cube with dot icon). Hold Shift then right-click to de-select and re-select a vertex you want to set all the selected points to, like you did to flatten the lakes. Press S, then Z, then 0, then Enter.
    • Switch back to Vertex select (cube with dot icon).

    • Hold Shift then right-click to de-select and re-select a vertex you want to set all the selected points to, like you did to flatten the lakes.

    • Press S, then Z, then 0, then Enter.

    • Press F to create a face that will be the bottom of the model.

  24. Switch back to Edge select (cube with line icon). Select the four edges of the square again (hold Shift and Alt) in addition to the bottom you just created. Navigate to the Mesh menu > Edges > Bridge Edge Loops.
    • Switch back to Edge select (cube with line icon).

    • Select the four edges of the square again (hold Shift and Alt) in addition to the bottom you just created.

    • Navigate to the Mesh menu > Edges > Bridge Edge Loops.

    • An "edge loop" is a loop of edges around a model, all connected in some way. In this case, we're connecting the loop consisting of the outside of the terrain with the loop that makes up the outside of the bottom, essentially "bridging" the gap between the edge loops.

  25. When you're happy with your model, switch back to Object mode. Make sure that the model is selected. It will have an orange border-- if not, right click on it. Export by navigating to the File menu > Export.
    • When you're happy with your model, switch back to Object mode.

    • Make sure that the model is selected. It will have an orange border-- if not, right click on it.

    • Export by navigating to the File menu > Export.

    • Choose a name and hit Export STL.

Conclusion

You should now have a 3D-printable model! Import into MatterControl or any other slicer to print.

Ryan Lutz

Member since: 06/30/2015

1,642 Reputation

15 Guides authored

0 Comments

Add Comment

View Statistics:

Past 24 Hours: 4

Past 7 Days: 7

Past 30 Days: 33

All Time: 1,904